Site Loader

Complément d’informations concernant la création d’un hotspot

Albert ON5AM il y a peu a écrit un article concernant la création d’un HotSpot. Cet article a pour but d’ajouter une partie, on va dire, « troubleshooting » ou retour d’expérience sur ce que j’ai dû faire pour que cela fonctionne 🙂

En effet, j’ai dû faire plus d’étapes pour que mon hotspot fonctionne :

Problème 1 :

Après avoir flashé la dernière version de l’image Pi-Star sur ma carte SD, j’ai allumé le Raspberry et là… rien, la led PWR du Raspberry restait rouge et la led ACT (toujours du Raspberry) ne s’allumait pas. Mon Raspberry pi est un modèle 3 B+ acheté récemment.

Ma solution :

Visiblement la dernière image Pi-Star stable (V3) contient une version de boot trop ancienne pour mon Raspberry. J’ai dû installer la V4 (actuellement en beta) : www.pistar.uk/beta/

Problème 2 :

Une fois dans la zone configuration du Pi-Star, j’ai ajouté ce qu’il fallait pour configurer mon HotSpot en YSF et DMR. Cependant après moultes essais, il m’était impossible par exemple de me connecter en wire-x avec celui-ci. Or avec la configuration mise (cf article d’Albert ON5AM, confirmé après recherche d’autres sources), cela aurait dû fonctionner, voir…  Construire son HotSpot rien de plus facile

Ma solution :

J’ai augmenté l’espace disque pour le Pi-Star. Je ne pense pas que cela aie eu un quelconque effet, mais il est toujours intéressant de le faire. Pour cela connectez-vous en SSH au Raspberry-Pi (via la commande ‘ssh’ sous linux ou sous windows ‘MobaXTerm’) et tapez la commande :
 « sudo pistar-expand » et redémarrez le Pi avec « sudo reboot ».
J’ai mis à jour Pi-Star :
« sudo pistar-update » et j’ai ensuite redémarré le Pi  « sudo reboot »
J’ai flashé le firmware du modem :
Il faut d’abord savoir le type de celui-ci, dans mon cas c’est : ‘MMDVM_HS_Hat board with 14.7456 MHz TCXO1 connected to GPIO’
Si vous n’êtes pas sûr tapez :  « sudo pistar-findmodem »
Ensuite suivant le type, tapez la commande de mise à jour, dans mon cas : « sudo pistar-mmdvmhshatflash hs_hat »
Sinon voici les différentes commandes possibles :

ZUMspot board connected to GPIO:
sudo pistar-zumspotflash rpi

  • ZUMspot duplex board connected to GPIO:
    sudo pistar-zumspotflash rpi_duplex
  • ZUMspot USB key:
    sudo pistar-zumspotflash usb
  • USB-connected Libre Modem:
    sudo pistar-zumspotflash libre
  • MMDVM_HS_Hat board with 14.7456 MHz TCXO1connected to GPIO:
    sudo pistar-mmdvmhshatflash hs_hat
  • MMDVM_HS_Hat board with 12.288 MHz TCXO connected to GPIO:
    sudo pistar-mmdvmhshatflash hs_hat-12mhz
  • MMDVM_HS_DUAL_Hat board with 14.7456 MHz TCXO connected to GPIO:
    sudo pistar-mmdvmhshatflash hs_dual_hat
  • MMDVM_HS_DUAL_Hat board with 12.288 MHz TCXO connected to GPIO:
    sudo pistar-mmdvmhshatflash hs_dual_hat-12mhz
  • Nano Hat board connected to GPIO:
    sudo pistar-vyehsflash nano_hs
  • HS_DUAL_HAT (VR2VYE) connected to GPIO:
    pistar-vyehsflash hs_dual_hat
  • NanoDV NPi board:
    sudo pistar-nanodvflash pi
  • NanoDV USB board:
    sudo pistar-nanodvflash usb
  • BD7KLE/BG3MDO devices:
    sudo pistar-mdoflash

(Source amateurradionotes.com )
Une fois les mises à jour faites, j’ai fait un factory reset :

config-pistar-1

Et ensuite j’ai tout reconfiguré dans l’ordre :

  • General Configuration
  • MMDVMHost Configuration (après avoir re-sélectionné le modem)
  • Yaesu System Fusion Configuration
  • Le RXOffset et le TXOffset dans l’onglet ‘expert’

Ensuite j’ai rebooté le Pi et hop ! Maintenant cela fonctionne 😛  😛 

config-pistar-2

Oui comme vous le voyez je n’ai configuré que l’YSF actuellement comme c’est ce que j’utilise le plus.

config-pistar-3

 par Julien | ON3DEX


Cet article est la propriété du site ON5VL ©

2+

Post Author: Albert